Mantle & Titanium is currently down for all sites

Incident Report for RFDSSE IT Systems

Resolved

This incident has been resolved.
Posted Jul 02, 2026 - 11:09 AEST

Identified

Confirmation Mantle is now back up and have confirmation staff can now access Mantle.
https://rfdsqld.atlassian.net/browse/JTC-74866

Confirmation Titanium is up and have confirmation Dental staff can now access Titanium
Titanium https://rfdsqld.atlassian.net/browse/JTC-74858
Posted Jul 02, 2026 - 10:29 AEST

Investigating

We are currently investigating with the vendor.

Mantle https://rfdsqld.atlassian.net/browse/JTC-74866
Titanium https://rfdsqld.atlassian.net/browse/JTC-74858
Posted Jul 02, 2026 - 09:52 AEST
This incident affected: Core Business Apps (Titanium, Mantle).